.
Just Released: Picasa Web Export Plugin for Lightroom

Adding to my stable of export plugins for Lightroom (Zenfolio, Smugmug and Flickr), I've just released my “Export to Picasa Web” Plugin for Lightroom.

I just hacked it out and it's received minimal testing by me (and no testing by anyone else), so version churn is likely at first as bugs are reported and shaken out. It comes with a French translation for all the parts that are the same as the other plugins, but the texts unique to this plugin remain in English until the French translator is able to send an update.

(If you're one of the unlucky few to get the dreaded “FormatW” error, you have my sympathies, but please don't report it to me because there's nothing I can do about it at this point.)

You can download the plugin from this page.


Comments so far....

Hi Jeffrey –

I currently use your Flickr export plugin for Lightroom (which works great – thanks!) and just downloaded your Picasaweb export plugin. After installing the new plugin and trying to export to my Picasaweb account, I received the following error message:

An internal error has occurred: [string "picasaweb.lua"]: 1258: attempt to call field ‘no_commas’ (a nil value)

Any idea what could be causing this error?

Thanks,
Jeff

Oops, upload error on my part. x.2 fixes it, I hope. —Jeffrey

— comment by Jeff on December 17th, 2007 at 11:46pm JST (6 years, 9 months ago) comment permalink

As it turns out, you request an email for login but I needed to use my “picasa username” which is different to your email address. Maybe you need to alter the text to say (email / username)?

— comment by Gordon McKinney on December 21st, 2007 at 12:33am JST (6 years, 9 months ago) comment permalink

Hi Jeffrey,

Triggert by this export plug-in I have a question.
Would it be possible to make a Export plug-in like the one in Lightroom with extra the possibility to add a develop preset. So the ability to have a certain develop preset be processed on all the photo’s to be exported.
Why? The printed photo’s I get back from the Lab I use are all to dark and to bleu. (I calibrated my monitor.) When I compare the printed photo with what I see on screen, I have to change the temp = – 20 and the brightness +10. This is the same for all the photo’s. So I thought that adding a develop preset to the export process my photo’s still look good on screen and are exported and printed by the Lab also good.

I hope you understand. My English is not so good.
Thanks,

Dick
the Netherlands

— comment by Dick on December 29th, 2007 at 8:06pm JST (6 years, 9 months ago) comment permalink

Hi,

I believe there’s an issue setting the title/caption of a photo if it contains a “&” symbol (XML escaping issue)? To reproduce, set the title of the photo in Lightroom to “A & B” and try uploading it to a picasa web album.

Thanks!

Thanks for the report; fixed in x.6 —Jeffrey

— comment by Andrew on December 30th, 2007 at 8:28am JST (6 years, 9 months ago) comment permalink

Thanks for this, works perfectly for me and is exactly what I was after.

I haven’t come across any of the issues above but I am still learning in regards to Lightroom.

Cheers

Kev

— comment by Kev on January 3rd, 2008 at 3:14pm JST (6 years, 9 months ago) comment permalink

Thank you very much for this one !

— comment by Maciej on January 9th, 2008 at 1:50am JST (6 years, 8 months ago) comment permalink

Jeff, would you be interested in creating a Lightroom export plugin for Phanfare? There are a number of us looking for one. You would receive a lifetime unlimited storage account in exchange according to Andrew, the CEO and President. I’m not affiliated with Phanfare, just a customer for two years.

Thanks for your consideration.

Brian

Phanfare has been suggested before, but last I looked into them they seemed to be doing their best to drive away their customers, so it’s not a very appealing proposition to put work into. —Jeffrey

— comment by bstring on February 18th, 2008 at 2:58am JST (6 years, 7 months ago) comment permalink

Jeffrey,

Aha, you’ve heard of the new version! To be fair, it’s a beta and they are very sensitive, historically, to user feedback. I’m confident (hopeful?) the released version will be much more to the liking of the beta testers.

Brian

— comment by bstring on February 18th, 2008 at 2:15pm JST (6 years, 7 months ago) comment permalink

I get “Can’t use Plugin” error.
The app says: “This plugin had an internal error”.

Look for a plugin_loader.log in your MyDocuments folder; it may have an error message indicating the problem.

Do you know how to reset this? I tried to remove the module and reinstall it, didn’t help.

I think it got confused when I was connected to the internet via proxy (from work). I initially connected to internet with no proxy and it was working fine.

Can you please help me.

Lightroom doesn’t support proxy connections, sorry. —Jeffrey

— comment by Murali on February 23rd, 2008 at 7:26am JST (6 years, 7 months ago) comment permalink

Hi Jeffrey,

I’m using your PicasaWeb export plugin which really works fine : ) Thx a lot !
Do you plan to implement the “update” function of PicasaWeb API so I can publish my photos to picasaweb and then push the modifications I did under Lightroom ?

I can already do it by selecting the “refresh” method + “erasing all the previously exported pictures”. The problem is : if people commented my photos the comments will go away. Which is quite a pity : ( It’s the same if I manually changed the tag in picasaweb’s albums.

So thx a lot for this excellent plugin. Please let me know if you’re planning to add this feature request. I would definitely enjoy it !

Cheers,
Guillaume

— comment by Guillaume on April 19th, 2008 at 6:44pm JST (6 years, 5 months ago) comment permalink

Are you conserding doing a plug-in for Web Shots?

— comment by Allan Barnett on May 25th, 2008 at 10:43am JST (6 years, 4 months ago) comment permalink

Thanks so much for this remarkable tool!

— comment by tdardas on June 25th, 2008 at 10:17pm JST (6 years, 3 months ago) comment permalink

Encounter error when create new album. See below for error message:

+45.7: At line 21811:
bad state:
+45.7: At line 21811
+45.7: At =(tail call) line -1
+45.7: At line 16719
+45.7: At line 16235

Fixed in version .41; thanks for the report. —Jeffrey

— comment by laputa on November 18th, 2008 at 4:36pm JST (5 years, 10 months ago) comment permalink
Leave a comment...


All comments are invisible to others until Jeffrey approves them.

Please mention what part of the world you're writing from, if you don't mind. It's always interesting to see where people are visiting from.

More or less plain text — see below for allowed markup

You can use the following tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Subscribe without commenting